summaryrefslogtreecommitdiffstats
path: root/abs/extra/ocaml
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-29 21:25:39 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-29 21:25:39 (GMT)
commitaa576d022474df1cd2394a4a18eddca8c8771f54 (patch)
treea978b1d3c5baaaf5a40f0a088bfd8270f00bbd13 /abs/extra/ocaml
parent84f2fc5bdd5a29c41849b75d9ff5cb5c0f72d622 (diff)
downloadlinhes_pkgbuild-aa576d022474df1cd2394a4a18eddca8c8771f54.zip
linhes_pkgbuild-aa576d022474df1cd2394a4a18eddca8c8771f54.tar.gz
linhes_pkgbuild-aa576d022474df1cd2394a4a18eddca8c8771f54.tar.bz2
ocaml: update to 4.02.3
Diffstat (limited to 'abs/extra/ocaml')
-rw-r--r--abs/extra/ocaml/PKGBUILD20
-rw-r--r--abs/extra/ocaml/fix-ocaml-binutils-2.21.patch66
l---------abs/extra/ocaml/ocaml-3.12.1-3.src.tar.gz1
3 files changed, 10 insertions, 77 deletions
diff --git a/abs/extra/ocaml/PKGBUILD b/abs/extra/ocaml/PKGBUILD
index e7ad5ec..f1b1343 100644
--- a/abs/extra/ocaml/PKGBUILD
+++ b/abs/extra/ocaml/PKGBUILD
@@ -1,30 +1,31 @@
-# $Id: PKGBUILD 143814 2011-11-29 13:33:35Z stephane $
+# $Id$
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgbase='ocaml'
pkgname=('ocaml' 'ocaml-compiler-libs')
-pkgver=3.12.1
-pkgrel=3
+pkgver=4.02.3
+pkgrel=2
pkgdesc="A functional language with OO extensions"
arch=('i686' 'x86_64')
-license=('LGPL2' 'custom: QPL-1.0')
+license=('LGPL2.1' 'custom: QPL-1.0')
url="http://caml.inria.fr/"
depends=('gdbm')
-makedepends=('tk' 'ncurses>=5.6-7' 'libx11')
+makedepends=('tk>=8.6.0' 'ncurses>=5.6-7' 'libx11')
optdepends=('ncurses: advanced ncurses features' 'tk: advanced tk features')
-source=(http://caml.inria.fr/distrib/ocaml-3.12/${pkgname}-${pkgver}.tar.gz)
-options=('!makeflags' '!emptydirs')
+source=(http://caml.inria.fr/distrib/ocaml-4.02/${pkgname}-${pkgver}.tar.gz)
+md5sums=('ef1a324608c97031cbd92a442d685ab7')
+options=('!makeflags' '!emptydirs' 'staticlibs')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure -prefix /usr
+ ./configure -prefix /usr -x11include /usr/include
make world.opt
}
package_ocaml() {
cd "${srcdir}/${pkgbase}-${pkgver}"
make PREFIX="${pkgdir}/usr" MANDIR="${pkgdir}/usr/share/man" install
-
+
# Save >10MB with this one, makepkg only strips debug symbols.
#find "${pkgdir}/usr/lib" -type f -name '*.so.*' -exec strip --strip-unneeded {} \;
@@ -54,4 +55,3 @@ optdepends=()
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
}
-md5sums=('814a047085f0f901ab7d8e3a4b7a9e65')
diff --git a/abs/extra/ocaml/fix-ocaml-binutils-2.21.patch b/abs/extra/ocaml/fix-ocaml-binutils-2.21.patch
deleted file mode 100644
index fa7664c..0000000
--- a/abs/extra/ocaml/fix-ocaml-binutils-2.21.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From: Stephane Glondu <steph@glondu.net>
-Date: Tue, 8 Mar 2011 21:17:40 +0100
-Subject: [PATCH] Fix ocamlopt w.r.t. binutils 2.21
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Bug: http://caml.inria.fr/mantis/view.php?id=5237
-Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=617404
-Authors: Eric Cooper, spiralvoice
-Reviewed-by: Stéphane Glondu <steph@glondu.net>
----
- asmcomp/amd64/emit.mlp | 13 +++++++------
- asmcomp/i386/emit.mlp | 6 +++---
- 2 files changed, 10 insertions(+), 9 deletions(-)
-
-diff --git a/asmcomp/amd64/emit.mlp b/asmcomp/amd64/emit.mlp
-index 4a3f844..525c6e6 100644
---- a/asmcomp/amd64/emit.mlp
-+++ b/asmcomp/amd64/emit.mlp
-@@ -679,17 +679,18 @@ let fundecl fundecl =
- emit_all true fundecl.fun_body;
- List.iter emit_call_gc !call_gc_sites;
- emit_call_bound_errors ();
-+ begin match Config.system with
-+ "linux" | "gnu" ->
-+ ` .type {emit_symbol fundecl.fun_name},@function\n`;
-+ ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
-+ | _ -> ()
-+ end;
- if !float_constants <> [] then begin
- if macosx
- then ` .literal8\n`
- else ` .section .rodata.cst8,\"a\",@progbits\n`;
- List.iter emit_float_constant !float_constants
-- end;
-- match Config.system with
-- "linux" | "gnu" ->
-- ` .type {emit_symbol fundecl.fun_name},@function\n`;
-- ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
-- | _ -> ()
-+ end
-
- (* Emission of data *)
-
-diff --git a/asmcomp/i386/emit.mlp b/asmcomp/i386/emit.mlp
-index 2992f29..0b1252c 100644
---- a/asmcomp/i386/emit.mlp
-+++ b/asmcomp/i386/emit.mlp
-@@ -905,12 +905,12 @@ let fundecl fundecl =
- emit_all true fundecl.fun_body;
- List.iter emit_call_gc !call_gc_sites;
- emit_call_bound_errors ();
-- List.iter emit_float_constant !float_constants;
-- match Config.system with
-+ begin match Config.system with
- "linux_elf" | "bsd_elf" | "gnu" ->
- ` .type {emit_symbol fundecl.fun_name},@function\n`;
- ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
-- | _ -> ()
-+ | _ -> () end;
-+ List.iter emit_float_constant !float_constants
-
-
- (* Emission of data *)
---
diff --git a/abs/extra/ocaml/ocaml-3.12.1-3.src.tar.gz b/abs/extra/ocaml/ocaml-3.12.1-3.src.tar.gz
deleted file mode 120000
index 140a1a6..0000000
--- a/abs/extra/ocaml/ocaml-3.12.1-3.src.tar.gz
+++ /dev/null
@@ -1 +0,0 @@
-/data/pkg_repo/src_packages/ocaml-3.12.1-3.src.tar.gz \ No newline at end of file