summaryrefslogtreecommitdiffstats
path: root/abs/extra/openjpeg
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/extra/openjpeg
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/extra/openjpeg')
-rw-r--r--abs/extra/openjpeg/30_fix_build_for_debian.dpatch70
-rw-r--r--abs/extra/openjpeg/PKGBUILD27
2 files changed, 97 insertions, 0 deletions
diff --git a/abs/extra/openjpeg/30_fix_build_for_debian.dpatch b/abs/extra/openjpeg/30_fix_build_for_debian.dpatch
new file mode 100644
index 0000000..afd9950
--- /dev/null
+++ b/abs/extra/openjpeg/30_fix_build_for_debian.dpatch
@@ -0,0 +1,70 @@
+
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 30_fix_build_for_debian.dpatch by <robin.cornelius@gmail.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Dont apply the -s strip flag to the shared lib debian will do it for us
+## DP: where necessary
+## DP: Remove unnecessary linkage on lstdc++ and lm and add missing linkage for -lm
+
+@DPATCH@
+
+Index: ./Makefile
+===================================================================
+--- ./Makefile (revision 96)
++++ ./Makefile (working copy)
+@@ -18,8 +18,7 @@
+ # Converts cr/lf to just lf
+ DOS2UNIX = dos2unix
+
+-COMPILERFLAGS = -Wall -O3 -ffast-math -std=c99 -fPIC
+-LIBRARIES = -lstdc++
++COMPILERFLAGS = -Wall -O3 -ffast-math -std=c99 -fPIC -g $(EXTRA_CFLAGS)
+
+ MODULES = $(SRCS:.c=.o)
+ CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
+@@ -54,7 +53,7 @@
+ $(AR) r $@ $(MODULES)
+
+ $(SHAREDLIB): $(MODULES)
+- $(CC) -s -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) $(LIBRARIES)
++ $(CC) -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) -lm
+
+ install: OpenJPEG
+ install -d '$(DESTDIR)$(INSTALL_LIBDIR)' '$(DESTDIR)$(INSTALL_INCLUDE)'
+
+Index: ./indexer_JPIP/Makefile
+===================================================================
+--- ./indexer_JPIP/Makefile (revision 95)
++++ ./indexer_JPIP/Makefile (working copy)
+@@ -1,7 +1,6 @@
+ CC = gcc
+
+-LDFLAGS = -lm
+-CFLAGS = -Wall
++CFLAGS = -Wall $(EXTRA_CFLAGS)
+
+ all: index_create
+
+Index: ./codec/Makefile
+===================================================================
+--- ./codec/Makefile (revision 96)
++++ ./codec/Makefile (working copy)
+@@ -1,13 +1,13 @@
+ # Makefile for the main OpenJPEG codecs: j2k_to_image and image_to_j2k
+
+-CFLAGS = -O3 -lstdc++ # -g -p -pg
++CFLAGS = $(EXTRA_CFLAGS) # -g -p -pg
+
+ all: j2k_to_image image_to_j2k
+
+-j2k_to_image: j2k_to_image.c ../libopenjpeg.a
++j2k_to_image: j2k_to_image.c
+ gcc $(CFLAGS) compat/getopt.c index.c convert.c j2k_to_image.c -o j2k_to_image -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+-image_to_j2k: image_to_j2k.c ../libopenjpeg.a
++image_to_j2k: image_to_j2k.c
+ gcc $(CFLAGS) compat/getopt.c index.c convert.c image_to_j2k.c -o image_to_j2k -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+ clean:
+
diff --git a/abs/extra/openjpeg/PKGBUILD b/abs/extra/openjpeg/PKGBUILD
new file mode 100644
index 0000000..087da2f
--- /dev/null
+++ b/abs/extra/openjpeg/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=openjpeg
+pkgver=1.3
+_pkgver=v1_3
+pkgrel=3
+pkgdesc="An open source JPEG 2000 codec"
+arch=(i686 x86_64)
+license=('BSD')
+url="http://www.openjpeg.org"
+depends=('glibc')
+source=(http://www.openjpeg.org/openjpeg_${_pkgver}.tar.gz
+ 30_fix_build_for_debian.dpatch)
+md5sums=('f9a3ccfa91ac34b589e9bf7577ce8ff9'
+ '2557f485513e77f6dcea77f4741c4fa1')
+
+build() {
+ cd "${srcdir}/OpenJPEG_${_pkgver}"
+ patch -Np1 -i "${srcdir}/30_fix_build_for_debian.dpatch" || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/openjpeg"
+ tr '\r' '\n' < license.txt > "${pkgdir}/usr/share/licenses/openjpeg/license.txt" || return 1
+ chmod 644 "${pkgdir}/usr/share/licenses/openjpeg/license.txt" || return 1
+ ln -s libopenjpeg.so.2 "${pkgdir}/usr/lib/libopenjpeg.so" || return 1
+}