summaryrefslogtreecommitdiffstats
path: root/abs/extra/openpht
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-01-09 22:35:58 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-01-09 22:35:58 (GMT)
commit6d4a8b005a7673da4c8238f66ed18f0f35cfc67a (patch)
tree26934155eabeb0cfa472489051c5e9adcbec9855 /abs/extra/openpht
parent31bfdbf7d7f8c335e19d5b5fc60c48ff8923422e (diff)
downloadlinhes_pkgbuild-6d4a8b005a7673da4c8238f66ed18f0f35cfc67a.zip
linhes_pkgbuild-6d4a8b005a7673da4c8238f66ed18f0f35cfc67a.tar.gz
linhes_pkgbuild-6d4a8b005a7673da4c8238f66ed18f0f35cfc67a.tar.bz2
openpht: update to 1.7.1.137
Diffstat (limited to 'abs/extra/openpht')
-rw-r--r--abs/extra/openpht/PKGBUILD21
-rw-r--r--abs/extra/openpht/__changelog1
-rw-r--r--abs/extra/openpht/plex_lib.conf2
-rwxr-xr-xabs/extra/openpht/plexhometheater.sh11
4 files changed, 9 insertions, 26 deletions
diff --git a/abs/extra/openpht/PKGBUILD b/abs/extra/openpht/PKGBUILD
index 6ccd7e9..06afae1 100644
--- a/abs/extra/openpht/PKGBUILD
+++ b/abs/extra/openpht/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
pkgname=openpht
-pkgver=1.6.2.123
-_pkghash=e23a7eef
-pkgrel=5
+pkgver=1.7.1.137
+_pkghash=b604995c
+pkgrel=2
pkgdesc='OpenPHT is a community driven fork of Plex Home Theater'
arch=('i686' 'x86_64')
url='https://github.com/RasPlex/OpenPHT/'
@@ -21,15 +21,15 @@ depends=('alsa-lib' 'avahi' 'boost-libs' 'curl' 'expat' 'ffmpeg2.8' 'freetype2'
'libxext' 'libxrandr' 'lzo' 'pcre' 'python2' 'sdl' 'sdl_image'
'sdl_mixer' 'sqlite' 'smbclient' 'taglib' 'tinyxml' 'yajl' 'zlib' 'rtmpdump')
makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'shairplay'
- 'libcec' 'libplist' 'nasm' 'swig' 'unzip' 'zip')
+ 'libcec' 'libplist' 'nasm' 'swig' 'unzip' 'zip' 'gcc-libs' 'glibc' 'llvm-libs')
optdepends=('libplist: AirPlay support'
'libcec: Pulse-Eight USB-CEC adapter support'
'shairplay: Shairplay Support')
source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.gz"
- 'plexhometheater.sh'
'plex_lib.conf'
'fribidi.patch'
'plexhometheater.desktop')
+
prepare() {
cd OpenPHT-${pkgver}-${_pkghash}
patch -Np1 <../fribidi.patch
@@ -57,11 +57,7 @@ package() {
cd OpenPHT-${pkgver}-${_pkghash}/build
make DESTDIR="${pkgdir}" install
- install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
- mv "${pkgdir}"/usr/bin/{system,xbmc-xrandr} "${pkgdir}"/usr/lib/plexhometheater/
- mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
- rm -rf "${pkgdir}"/usr/bin/*.so
- install -Dm 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/LH/bin/plexhometheater.sh
+ install -dm 755 "${pkgdir}"/usr/{share/{applications,pixmaps}}
install -m 644 "${srcdir}"/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
@@ -69,8 +65,7 @@ package() {
# add in plex_lib.conf
install -D -m0744 ${srcdir}/plex_lib.conf ${pkgdir}/etc/gen_lib_xml.d/plex_lib.conf
}
-md5sums=('075d697793b32d34c9ac57b94ae14821'
- 'ad57396d98692dbe8c8d6f2fab707a94'
- 'c1eedd9f89ee727230833db9ef1e5d29'
+md5sums=('9a7a2205a30f1002b2600cf8e240fb98'
+ 'b9524fe29d0cc65087ba447d1b892da2'
'a5980579c1b6341a6d06e80d9da2a924'
'e530e2b4d8333863ba1c87862c291ba1')
diff --git a/abs/extra/openpht/__changelog b/abs/extra/openpht/__changelog
index 6daae7f..140f8a0 100644
--- a/abs/extra/openpht/__changelog
+++ b/abs/extra/openpht/__changelog
@@ -2,5 +2,4 @@ copied plex-home-theater to openpht
PKGBUILD - Remove opt dep pulseaudio
PKGBUILD - Add dep ffmpeg2.8
PKGBUILD - Added plex_lib.conf, this file goes in /etc/gen_lib_xml.d/
-PKGBUILD - Install plexhometheater.sh to /usr/LH/bin
openpht.install - add gen_lib_xml.py to post_install and post_remove and post_update
diff --git a/abs/extra/openpht/plex_lib.conf b/abs/extra/openpht/plex_lib.conf
index 1aa78f3..e85d31d 100644
--- a/abs/extra/openpht/plex_lib.conf
+++ b/abs/extra/openpht/plex_lib.conf
@@ -3,7 +3,7 @@
<type>MENU_PLEX</type>
<text>Launch Plex</text>
<description>Open Plex Home Theater</description>
- <action>EXEC /usr/LH/bin/plexhometheater.sh</action>
+ <action>EXEC /usr/bin/openpht</action>
</button>
<!--#PLEX-->
diff --git a/abs/extra/openpht/plexhometheater.sh b/abs/extra/openpht/plexhometheater.sh
deleted file mode 100755
index 16da77d..0000000
--- a/abs/extra/openpht/plexhometheater.sh
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-#Stop XScreensaver
-stop_xss.sh &
-
-#Launch plex
-export XBMC_BIN_HOME='/usr/lib/plexhometheater'
-export XBMC_HOME='/usr/share/plexhometheater'
-exec plexhometheater
-
-#Start Xscreensaver again
-killall stop_xss.sh