summaryrefslogtreecommitdiffstats
path: root/abs/extra/postgresql/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-02 23:35:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-02 23:35:59 (GMT)
commitfd8405efa6e0c17c9e666f5ea8584039f31a5168 (patch)
tree641cafbb31cb0387ac10b0641427d850d15a4b93 /abs/extra/postgresql/PKGBUILD
parent1577770bf29c22dd1a2e14c055b5af2f1408eb39 (diff)
downloadlinhes_pkgbuild-fd8405efa6e0c17c9e666f5ea8584039f31a5168.zip
linhes_pkgbuild-fd8405efa6e0c17c9e666f5ea8584039f31a5168.tar.gz
linhes_pkgbuild-fd8405efa6e0c17c9e666f5ea8584039f31a5168.tar.bz2
postgresql: update to 10.2
Diffstat (limited to 'abs/extra/postgresql/PKGBUILD')
-rw-r--r--abs/extra/postgresql/PKGBUILD162
1 files changed, 87 insertions, 75 deletions
diff --git a/abs/extra/postgresql/PKGBUILD b/abs/extra/postgresql/PKGBUILD
index a00160c..c1a35dc 100644
--- a/abs/extra/postgresql/PKGBUILD
+++ b/abs/extra/postgresql/PKGBUILD
@@ -1,86 +1,111 @@
-# $Id: PKGBUILD 160730 2012-06-04 17:58:05Z dan $
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Maintainer: Dan McGee <dan@archlinux.org>
pkgbase=postgresql
pkgname=('postgresql-libs' 'postgresql-docs' 'postgresql')
-pkgver=9.1.4
+pkgver=10.2
_majorver=${pkgver%.*}
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://www.postgresql.org/"
+pkgdesc='Sophisticated object-relational DBMS'
+url='https://www.postgresql.org/'
+arch=('x86_64')
license=('custom:PostgreSQL')
-makedepends=('krb5' 'libxml2' 'python2' 'perl' 'tcl' 'openssl>=1.0.0')
-source=(ftp://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
- postgresql.rcd postgresql.confd postgresql.pam postgresql.logrotate)
+makedepends=('krb5' 'libxml2' 'python2' 'perl' 'tcl>=8.6.0' 'openssl>=1.0.0' 'pam' 'zlib')
+source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
+ postgresql-run-socket.patch
+ postgresql.pam
+ postgresql.logrotate
+ postgresql.service
+ postgresql-check-db-dir)
+sha256sums=('fe32009b62ddb97f7f014307ce9d0edb6972f5a698e63cb531088e147d145bad'
+ '8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e'
+ 'b48fe97f8e43ed0d2041d519119a4dafb70fcae72870951bf4fb7350fe169ac8'
+ '888a1d44f03fccfa4bf344ee45824fefb846ae3c1c0c40113ad6020b4be3b0cf')
+sha512sums=('bac61644c12c31e2dce97ec0134902a2a7141e922619015425961b963961b21210ca840f59ba585d3d75c7e34cb640f2ebeaa2b25c4a866db68f5e73a8f8a448'
+ '031efe12d18ce386989062327cdbbe611c5ef1f94e4e1bead502304cb3e2d410af533d3c7f1109d24f9da9708214fe32f9a10ba373a3ca8d507bdb521fbb75f7'
+ '1e6183ab0eb812b3ef687ac2c26ce78f7cb30540f606d20023669ac00ba04075487fb72e4dc89cc05dab0269ff6aca98fc1167cc75669c225b88b592482fbf67'
+ '9ab4da01337ffbab8faec0e220aaa2a642dbfeccf7232ef2645bdc2177a953f17ee3cc14a4d8f8ebd064e1dae8b3dba6029adbffb8afaabea383963213941ba8'
+ 'ec2625c3ccfb6c142ea12ef4392b00f3d4cb0a5411d603b98157d55cd162ed3b422dbbd42e8b13211063db94a42f6d1f3febd4acaadde69ea17bfd8eccae3539'
+ '56974ef34a8d94596068413154b1a7ed5a71f5a3942bd79427f05e6f6b7853036874dedd8d988bb94306023f2a675996d500b075eaf8a192ef5c24026eb28eb0')
+
+prepare() {
+ cd postgresql-${pkgver}
+ patch -p1 < ../postgresql-run-socket.patch
+}
build() {
- cd "${srcdir}/postgresql-${pkgver}"
-
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --datadir=/usr/share/postgresql \
- --with-krb5 \
- --with-libxml \
- --with-openssl \
- --with-perl \
- --with-python PYTHON=/usr/bin/python2 \
- --with-tcl \
- --with-pam \
- --with-system-tzdata=/usr/share/zoneinfo \
- --enable-nls \
- --enable-thread-safety
-
+ cd postgresql-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/postgresql \
+ --sysconfdir=/etc \
+ --with-gssapi \
+ --with-libxml \
+ --with-openssl \
+ --with-perl \
+ --with-python PYTHON=/usr/bin/python2 \
+ --with-tcl \
+ --with-pam \
+ --with-system-tzdata=/usr/share/zoneinfo \
+ --with-uuid=e2fs \
+ --enable-nls \
+ --enable-thread-safety
make world
}
package_postgresql-libs() {
pkgdesc="Libraries for use with PostgreSQL"
- depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0')
+ depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0' 'zlib')
provides=('postgresql-client')
conflicts=('postgresql-client')
- cd "${srcdir}/postgresql-${pkgver}"
+ cd postgresql-${pkgver}
# install license
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/postgresql-libs/LICENSE"
+ install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
- # install libs
- for dir in src/interfaces src/bin/pg_config src/bin/psql; do
+ # install libs and non-server binaries
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
make -C ${dir} DESTDIR="${pkgdir}" install
done
- install -D -m644 doc/src/sgml/man1/pg_config.1 "${pkgdir}/usr/share/man/man1/pg_config.1"
- install -D -m644 doc/src/sgml/man1/psql.1 "${pkgdir}/usr/share/man/man1/psql.1"
+ for util in pg_config pg_dump pg_dumpall pg_restore psql \
+ clusterdb createdb createuser dropdb dropuser pg_isready reindexdb vacuumdb; do
+ install -Dm 644 doc/src/sgml/man1/${util}.1 "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
cd src/include
mkdir -p "${pkgdir}"/usr/include/{libpq,postgresql/internal/libpq}
# these headers are needed by the public headers of the interfaces
- install -m644 pg_config.h "${pkgdir}/usr/include/"
- install -m644 pg_config_os.h "${pkgdir}/usr/include/"
- install -m644 postgres_ext.h "${pkgdir}/usr/include/"
- install -m644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq/"
- install -m644 pg_config_manual.h "${pkgdir}/usr/include/"
-
- # these headers are needed by the not-so-public headers of the interfaces
- install -m644 c.h "${pkgdir}/usr/include/postgresql/internal/"
- install -m644 port.h "${pkgdir}/usr/include/postgresql/internal/"
- install -m644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal/"
- install -m644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq/"
+ install -m 644 pg_config.h "${pkgdir}/usr/include"
+ install -m 644 pg_config_os.h "${pkgdir}/usr/include"
+ install -m 644 pg_config_ext.h "${pkgdir}/usr/include"
+ install -m 644 postgres_ext.h "${pkgdir}/usr/include"
+ install -m 644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq"
+ install -m 644 pg_config_manual.h "${pkgdir}/usr/include"
+
+ # these he aders are needed by the not-so-public headers of the interfaces
+ install -m 644 c.h "${pkgdir}/usr/include/postgresql/internal"
+ install -m 644 port.h "${pkgdir}/usr/include/postgresql/internal"
+ install -m 644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal"
+ install -m 644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq"
}
package_postgresql-docs() {
pkgdesc="HTML documentation for PostgreSQL"
- options=(docs)
+ options=('docs')
- cd "${srcdir}/postgresql-${pkgver}"
+ cd postgresql-${pkgver}
- # install license
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/postgresql-docs/LICENSE"
+ install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
make -C doc/src/sgml DESTDIR="${pkgdir}" install-html
- chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html/"
+ chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html"
# clean up
rmdir "${pkgdir}"/usr/share/man/man{1,3,7}
@@ -88,16 +113,17 @@ package_postgresql-docs() {
}
package_postgresql() {
- pkgdesc="A sophisticated object-relational DBMS"
- backup=('etc/conf.d/postgresql' 'etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
- depends=("postgresql-libs>=${pkgver}" 'krb5' 'libxml2' 'readline>=6.0' 'openssl>=1.0.0')
+ pkgdesc='Sophisticated object-relational DBMS'
+ backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
+ depends=("postgresql-libs>=${pkgver}" 'krb5' 'libxml2' 'readline>=6.0' 'openssl>=1.0.0' 'pam')
optdepends=('python2: for PL/Python support'
'perl: for PL/Perl support'
'tcl: for PL/Tcl support'
'postgresql-old-upgrade: upgrade from previous major version using pg_upgrade')
+ options=('staticlibs')
install=postgresql.install
- cd "${srcdir}/postgresql-${pkgver}"
+ cd postgresql-${pkgver}
# install
make DESTDIR="${pkgdir}" install
@@ -105,14 +131,16 @@ package_postgresql() {
make -C doc/src/sgml DESTDIR="${pkgdir}" install-man
# we don't want these, they are in the -libs package
- for dir in src/interfaces src/bin/pg_config src/bin/psql; do
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
make -C ${dir} DESTDIR="${pkgdir}" uninstall
done
- rm "${pkgdir}/usr/share/man/man1/pg_config.1"
- rm "${pkgdir}/usr/share/man/man1/psql.1"
+ for util in pg_config pg_dump pg_dumpall pg_restore psql \
+ clusterdb createdb createuser dropdb dropuser pg_isready reindexdb vacuumdb; do
+ rm "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
# install license
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+ install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
# clean up unneeded installed items
rm -rf "${pkgdir}/usr/include/postgresql/internal"
@@ -120,27 +148,11 @@ package_postgresql() {
find "${pkgdir}/usr/include" -maxdepth 1 -type f -execdir rm {} +
rmdir "${pkgdir}/usr/share/doc/postgresql/html"
- # install launch script
- install -D -m755 "${srcdir}/postgresql.rcd" "${pkgdir}/etc/rc.d/postgresql"
-
- # install conf file
- install -D -m644 ${srcdir}/postgresql.confd \
- "${pkgdir}/etc/conf.d/postgresql"
+ install -Dm 644 "${srcdir}/postgresql.service" -t "${pkgdir}/usr/lib/systemd/system"
+ install -Dm 755 "${srcdir}/postgresql-check-db-dir" -t "${pkgdir}/usr/bin"
- install -D -m644 ${srcdir}/postgresql.pam \
- "${pkgdir}/etc/pam.d/postgresql"
-
- install -D -m644 ${srcdir}/postgresql.logrotate \
- "${pkgdir}/etc/logrotate.d/postgresql"
+ install -Dm 644 "${srcdir}/postgresql.pam" "${pkgdir}/etc/pam.d/postgresql"
+ install -Dm 644 "${srcdir}/postgresql.logrotate" "${pkgdir}/etc/logrotate.d/postgresql"
}
-md5sums=('a8035688dba988b782725ac1aec60186'
- '1ddd1df8010549f237e7983bb326025e'
- 'a54d09a20ab1672adf08f037df188d53'
- '96f82c38f3f540b53f3e5144900acf17'
- 'd28e443f9f65a5712c52018b84e27137')
-sha256sums=('a0795a8eb3ae2d1a2914b63bf143d20182835d90699915ff43567c041d3c9712'
- '9f6307b1358892e304f9474a456f0cb9160cfb8812a9da0430abe647f8a9cf45'
- '3de5c059eead8816db15c2c5588e6196d6c4b0d704faf1a20912796cf589ba81'
- '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
- '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e')
+# vim: ts=2 sw=2 et: