summaryrefslogtreecommitdiffstats
path: root/abs/extra/unison
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/extra/unison
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/extra/unison')
-rw-r--r--abs/extra/unison/PKGBUILD22
-rw-r--r--abs/extra/unison/ocaml-3.08-extnames.patch14
2 files changed, 19 insertions, 17 deletions
diff --git a/abs/extra/unison/PKGBUILD b/abs/extra/unison/PKGBUILD
index b1efa5b..6b3dc00 100644
--- a/abs/extra/unison/PKGBUILD
+++ b/abs/extra/unison/PKGBUILD
@@ -1,8 +1,8 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 57697 2009-11-01 15:08:02Z tpowa $
#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=unison
-pkgver=2.27.57
+pkgver=2.32.52
pkgrel=1
pkgdesc="Unison is a file-synchronization tool"
arch=(i686 x86_64)
@@ -10,6 +10,7 @@ license=('GPL2')
url="http://www.cis.upenn.edu/~bcpierce/unison"
depends=('glibc')
#makedepends=('ocaml' 'lablgtk' 'lablgtk2' 'imagemagick')
+#makedepends=('ocaml' 'imagemagick')
makedepends=('ocaml' )
source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/$pkgname-$pkgver.tar.gz \
$pkgname.desktop)
@@ -23,6 +24,21 @@ build() {
make UISTYLE=text DEBUGGING=false THREADS=true || return 1
mkdir -p $startdir/pkg/usr/bin
install -Dm755 unison $startdir/pkg/usr/bin/unison
+ # clean the builddir and rebuild with gtk support
+# make clean
+# make UISTYLE=gtk DEBUGGING=false THREADS=true || return 1
+# install -Dm755 unison $startdir/pkg/usr/bin/unison-gtk
+ # clean the builddir and rebuild with gtk2 support
+# make clean
+# make UISTYLE=gtk2 DEBUGGING=false THREADS=true || return 1
+# install -Dm755 unison $startdir/pkg/usr/bin/unison-gtk2
+ # install a .desktop file; create a compliant icon from ico file and install the png
+ # install -Dm644 ../$pkgname.desktop $startdir/pkg/usr/share/applications/$pkgname.desktop
+ # convert win32rc/U.ico unison.png
+ # install -Dm644 ${pkgname}-1.png $startdir/pkg/usr/share/pixmaps/$pkgname.png
+ # make symlink for .desktop file
+ # cd $startdir/pkg//usr/bin
+ # ln -s unison-gtk2 unison-x11
}
-md5sums=('4ba0a3e4bf4b4ad0c063f86391371f78'
+md5sums=('0701f095c1721776a0454b94607eda48'
'2daecba7705455a8e4b769e48b059872')
diff --git a/abs/extra/unison/ocaml-3.08-extnames.patch b/abs/extra/unison/ocaml-3.08-extnames.patch
deleted file mode 100644
index e959be2..0000000
--- a/abs/extra/unison/ocaml-3.08-extnames.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur unison-2.9.1/ubase/uprintf.ml unison-2.9.1.patched/ubase/uprintf.ml
---- unison-2.9.1/ubase/uprintf.ml 2002-04-11 07:13:23.000000000 +0200
-+++ unison-2.9.1.patched/ubase/uprintf.ml 2004-08-08 14:10:09.784776851 +0200
-@@ -10,8 +10,8 @@
- (* *)
- (***********************************************************************)
-
--external format_int: string -> int -> string = "format_int"
--external format_float: string -> float -> string = "format_float"
-+external format_int: string -> int -> string = "caml_format_int"
-+external format_float: string -> float -> string = "caml_format_float"
-
- let fprintf outchan doafter format =
- let format = (Obj.magic format : string) in