summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-15 22:23:30 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-15 22:23:30 (GMT)
commit62df34a9ded09d82a7b192da7534313c81b58eb0 (patch)
tree5812ad775367b2b68399055b13d532b912d1f37e /abs/extra
parent5884451d32518256cc1e41a9206678bb2153e0a0 (diff)
downloadlinhes_pkgbuild-62df34a9ded09d82a7b192da7534313c81b58eb0.zip
linhes_pkgbuild-62df34a9ded09d82a7b192da7534313c81b58eb0.tar.gz
linhes_pkgbuild-62df34a9ded09d82a7b192da7534313c81b58eb0.tar.bz2
htop: update to 2.2.0
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/htop/0001-fix-option-string.patch25
-rw-r--r--abs/extra/htop/PKGBUILD36
2 files changed, 49 insertions, 12 deletions
diff --git a/abs/extra/htop/0001-fix-option-string.patch b/abs/extra/htop/0001-fix-option-string.patch
new file mode 100644
index 0000000..d877e03
--- /dev/null
+++ b/abs/extra/htop/0001-fix-option-string.patch
@@ -0,0 +1,25 @@
+From 731acc8bced18c90fbe0e18381c32f007f71e0d9 Mon Sep 17 00:00:00 2001
+From: Christian Hesse <mail@eworm.de>
+Date: Tue, 10 Apr 2018 16:21:46 +0200
+Subject: [PATCH 1/1] fix option string
+
+This broke with commit db05ba61065f64b59d0014518be0786b5439e54c.
+
+Signed-off-by: Christian Hesse <mail@eworm.de>
+---
+ htop.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/htop.c b/htop.c
+index 6db81dd..678a3b8 100644
+--- a/htop.c
++++ b/htop.c
+@@ -93,7 +93,7 @@ static CommandLineSettings parseArguments(int argc, char** argv) {
+
+ int opt, opti=0;
+ /* Parse arguments */
+- while ((opt = getopt_long(argc, argv, "hvCst::d:u:p:i", long_opts, &opti))) {
++ while ((opt = getopt_long(argc, argv, "hvCs:td:u:p:i", long_opts, &opti))) {
+ if (opt == EOF) break;
+ switch (opt) {
+ case 'h':
diff --git a/abs/extra/htop/PKGBUILD b/abs/extra/htop/PKGBUILD
index 531cf81..09664d5 100644
--- a/abs/extra/htop/PKGBUILD
+++ b/abs/extra/htop/PKGBUILD
@@ -1,22 +1,33 @@
# $Id$
-# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=htop
-pkgver=2.0.1
-pkgrel=1
+pkgver=2.2.0
+pkgrel=2
pkgdesc="Interactive process viewer"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://hisham.hm/htop/"
license=('GPL')
-depends=('ncurses')
-makedepends=('python2')
+depends=('ncurses' 'libnl')
+makedepends=('python')
optdepends=('lsof: show files opened by a process'
'strace: attach to a running process')
-options=('!emptydirs')
-source=("http://hisham.hm/$pkgname/releases/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('f75fe92b4defaa80d99109830f34b5e2')
+options=('!emptydirs' debug)
+validpgpkeys=('8460980B2B79786DE0C7FCC83FD8F43C2BB3C478') # Hisham Muhammad <h@hisham.hm>
+source=("https://hisham.hm/$pkgname/releases/$pkgver/$pkgname-$pkgver.tar.gz"{,.asc}
+ '0001-fix-option-string.patch')
+sha256sums=('d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57'
+ 'SKIP'
+ 'e0ea3a91dfbc7f8c516a19e0d8890314845e768ea4132dfaa49c4d4e89ec10ca')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -Np1 < "${srcdir}"/0001-fix-option-string.patch
+}
build() {
cd "$pkgname-$pkgver"
@@ -24,10 +35,11 @@ build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --enable-unicode \
+ --enable-cgroup \
+ --enable-delayacct \
--enable-openvz \
- --enable-vserver \
- --enable-cgroup
+ --enable-unicode \
+ --enable-vserver
make
}