summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-12-30 20:33:31 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-12-30 20:33:31 (GMT)
commit835bc35ade1cde55470a781b60e4f45032cdef9a (patch)
treeeeddfe7247631c166f33c119ad7daf46d5d70f2a /abs/extra
parentc9ae566e45dcf7ff871c9c6cb0a5b961ba13be92 (diff)
downloadlinhes_pkgbuild-835bc35ade1cde55470a781b60e4f45032cdef9a.zip
linhes_pkgbuild-835bc35ade1cde55470a781b60e4f45032cdef9a.tar.gz
linhes_pkgbuild-835bc35ade1cde55470a781b60e4f45032cdef9a.tar.bz2
replace plex-home-theater with openpht
update to openpht 1.5.0 plex home theater will not be updated anymore so moving to the community driven fork openpht
Diffstat (limited to 'abs/extra')
-rwxr-xr-xabs/extra/openpht/PKGBUILD (renamed from abs/extra/plex-home-theater/PKGBUILD)29
-rw-r--r--abs/extra/openpht/__changelog (renamed from abs/extra/plex-home-theater/__changelog)3
-rw-r--r--abs/extra/openpht/openpht.install (renamed from abs/extra/plex-home-theater/plex-home-theater.install)0
-rwxr-xr-xabs/extra/openpht/plex-ffmpeg-compat.patch (renamed from abs/extra/plex-home-theater/plex-ffmpeg-compat.patch)0
-rw-r--r--abs/extra/openpht/plex-libcec.patch (renamed from abs/extra/plex-home-theater/plex-libcec.patch)0
-rw-r--r--abs/extra/openpht/plex_lib.conf (renamed from abs/extra/plex-home-theater/plex_lib.conf)0
-rwxr-xr-xabs/extra/openpht/plexhometheater.sh (renamed from abs/extra/plex-home-theater/plexhometheater.sh)0
7 files changed, 16 insertions, 16 deletions
diff --git a/abs/extra/plex-home-theater/PKGBUILD b/abs/extra/openpht/PKGBUILD
index 6de7cb1..d3e557e 100755
--- a/abs/extra/plex-home-theater/PKGBUILD
+++ b/abs/extra/openpht/PKGBUILD
@@ -1,16 +1,15 @@
-# $Id$
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
-
-pkgname=plex-home-theater
-pkgver=1.4.1.469
-_pkghash=47a90f01
-pkgrel=2
-pkgdesc='Plex Home Theater'
+pkgname=openpht
+pkgver=1.5.0.502
+_pkghash=7563ca94
+pkgrel=1
+pkgdesc='OpenPHT a community driven fork of Plex Home Theater'
arch=('i686' 'x86_64')
-url='http://www.plexapp.com/'
+url='https://github.com/RasPlex/OpenPHT'
license=('GPL2')
install="${pkgname}.install"
+provides=('plex-home-theater')
+#conflicts=('plex-home-theater')
+replaces=('plex-home-theater')
depends=('boost-libs' 'curl' 'ffmpeg-compat' 'glew' 'libcdio' 'libmad'
'libmicrohttpd' 'libmpeg2' 'libsamplerate' 'libssh' 'libusb-compat'
'libvdpau' 'libxrandr' 'lzo' 'sdl_image' 'sdl_mixer' 'smbclient'
@@ -20,21 +19,21 @@ makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'libcec'
optdepends=('libplist: AirPlay support'
'libshairport: AirPlay support'
'libcec: Pulse-Eight USB-CEC adapter support')
-source=("https://github.com/plexinc/plex-home-theater-public/archive/v${pkgver}-${_pkghash}.tar.gz"
+source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.gz"
'plex-ffmpeg-compat.patch'
'plex-libcec.patch'
'plex_lib.conf'
'plexhometheater.sh')
prepare() {
- cd plex-home-theater-public-${pkgver}-${_pkghash}
+ cd OpenPHT-${pkgver}-${_pkghash}
patch -Np1 -i ../plex-libcec.patch
patch -Np1 -i ../plex-ffmpeg-compat.patch
}
build() {
- cd plex-home-theater-public-${pkgver}-${_pkghash}
+ cd OpenPHT-${pkgver}-${_pkghash}
if [[ -d build ]]; then
rm -rf build
@@ -55,7 +54,7 @@ build() {
}
package() {
- cd plex-home-theater-public-${pkgver}-${_pkghash}/build
+ cd OpenPHT-${pkgver}-${_pkghash}/build
make DESTDIR="${pkgdir}" install
install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
@@ -72,7 +71,7 @@ package() {
}
# vim: ts=2 sw=2 et:
-md5sums=('62456ec6266f769f2c873ed7132b26d3'
+md5sums=('48ab91fe4ce6c6e6c6a3177e12d733dc'
'6704244166497db7fa6b3ddd43a0e53b'
'0f753e1ebea13e5a2029a59b9db79877'
'c1eedd9f89ee727230833db9ef1e5d29'
diff --git a/abs/extra/plex-home-theater/__changelog b/abs/extra/openpht/__changelog
index e631336..42c86d8 100644
--- a/abs/extra/plex-home-theater/__changelog
+++ b/abs/extra/openpht/__changelog
@@ -1,4 +1,5 @@
+copied plex-home-theater to openpht
PKGBUILD - Remove opt dep pulseaudio
PKGBUILD - Added plex_lib.conf, this file goes in /etc/gen_lib_xml.d/
PKGBUILD - Install plexhometheater.sh to /usr/LH/bin
-plexhometheater.install - add gen_lib_xml.py to post_install and post_remove and post_update
+openpht.install - add gen_lib_xml.py to post_install and post_remove and post_update
diff --git a/abs/extra/plex-home-theater/plex-home-theater.install b/abs/extra/openpht/openpht.install
index 6788abc..6788abc 100644
--- a/abs/extra/plex-home-theater/plex-home-theater.install
+++ b/abs/extra/openpht/openpht.install
diff --git a/abs/extra/plex-home-theater/plex-ffmpeg-compat.patch b/abs/extra/openpht/plex-ffmpeg-compat.patch
index 1601500..1601500 100755
--- a/abs/extra/plex-home-theater/plex-ffmpeg-compat.patch
+++ b/abs/extra/openpht/plex-ffmpeg-compat.patch
diff --git a/abs/extra/plex-home-theater/plex-libcec.patch b/abs/extra/openpht/plex-libcec.patch
index 2087569..2087569 100644
--- a/abs/extra/plex-home-theater/plex-libcec.patch
+++ b/abs/extra/openpht/plex-libcec.patch
diff --git a/abs/extra/plex-home-theater/plex_lib.conf b/abs/extra/openpht/plex_lib.conf
index 1aa78f3..1aa78f3 100644
--- a/abs/extra/plex-home-theater/plex_lib.conf
+++ b/abs/extra/openpht/plex_lib.conf
diff --git a/abs/extra/plex-home-theater/plexhometheater.sh b/abs/extra/openpht/plexhometheater.sh
index 579bed6..579bed6 100755
--- a/abs/extra/plex-home-theater/plexhometheater.sh
+++ b/abs/extra/openpht/plexhometheater.sh