summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-29 22:11:45 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-29 22:11:45 (GMT)
commitbfd89de7d3d8c84844d3649f598cb119bae7a1a5 (patch)
treef88295df25d7657b90b194070b850dc823f82a03 /abs/extra
parente3dfe57abfa410573d3fb8ddb22e73744f1a1804 (diff)
downloadlinhes_pkgbuild-bfd89de7d3d8c84844d3649f598cb119bae7a1a5.zip
linhes_pkgbuild-bfd89de7d3d8c84844d3649f598cb119bae7a1a5.tar.gz
linhes_pkgbuild-bfd89de7d3d8c84844d3649f598cb119bae7a1a5.tar.bz2
google-chrome: update to 34.0.1847.132
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/google-chrome/PKGBUILD16
-rw-r--r--abs/extra/google-chrome/google-chrome.install27
2 files changed, 32 insertions, 11 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index ca4ae42..c4357a3 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,7 +5,7 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=34.0.1847.116
+pkgver=34.0.1847.132
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('i686' 'x86_64')
@@ -16,16 +16,15 @@ depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfb
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
'ttf-google-fonts-git')
provides=("google-chrome=${pkgver}")
-conflicts=('google-chrome<35')
replaces=('chromium')
options=('!emptydirs' '!strip')
install=${pkgname}.install
_channel=stable
_arch=i386
[ "${CARCH}" = 'x86_64' ] && _arch=amd64
-source=("google-chrome-${_channel}_${pkgver}_${_arch}.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_${_arch}.deb"
- 'https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html')
-[ "${CARCH}" = 'x86_64' ] && md5sums[0]='f0186cc5b1f6ceb0166abb0628182663'
+source=("google-chrome-${_channel}_${pkgver}_${_arch}.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_${_arch}.deb")
+md5sums=('7a25fe96c07da3f0da72783788aad054')
+[ "${CARCH}" = 'x86_64' ] && md5sums[0]='54515de584acbe880a0adcc828e3173a'
package() {
msg2 "Extracting the data.tar.lzma"
@@ -42,7 +41,9 @@ package() {
gzip "${pkgdir}"/usr/share/man/man1/google-chrome.1
# License
- install -Dm644 eula_text.html "${pkgdir}"/usr/share/licenses/google-chrome/eula_text.html
+ install -d "${pkgdir}"/usr/share/licenses/google-chrome/
+ curl -Ls https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html \
+ -o "${pkgdir}"/usr/share/licenses/google-chrome/eula_text.html
msg2 "Symlinking missing Udev lib"
ln -s /usr/lib/libudev.so.1 "${pkgdir}"/opt/google/chrome/libudev.so.0
@@ -53,7 +54,4 @@ package() {
msg2 "Rename google-chrome-stable to google-chrome"
mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome
-
}
-md5sums=('f0186cc5b1f6ceb0166abb0628182663'
- '6d57da7476a4b1b7a81821d9c036425c')
diff --git a/abs/extra/google-chrome/google-chrome.install b/abs/extra/google-chrome/google-chrome.install
index 4b923b2..5d42e84 100644
--- a/abs/extra/google-chrome/google-chrome.install
+++ b/abs/extra/google-chrome/google-chrome.install
@@ -1,16 +1,39 @@
-post_install() {
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} $1${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+ msg_blue "Updating icon cache.."
gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_install() {
+ _update
if [ ! -e /usr/bin/chromium ]; then
ln -s /usr/bin/google-chrome /usr/bin/chromium
fi
}
+
post_upgrade() {
post_install
}
+
post_remove() {
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ _update
if [ -h /usr/bin/chromium ]; then
rm /usr/bin/chromium
fi