summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/mcpp
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/mcpp
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/mcpp')
-rw-r--r--abs/not_built/core/mcpp/PKGBUILD23
-rw-r--r--abs/not_built/core/mcpp/mcpp-2.6.4-patch22
2 files changed, 45 insertions, 0 deletions
diff --git a/abs/not_built/core/mcpp/PKGBUILD b/abs/not_built/core/mcpp/PKGBUILD
new file mode 100644
index 0000000..57dae67
--- /dev/null
+++ b/abs/not_built/core/mcpp/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 22398 2008-12-26 17:32:45Z jgc $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=mcpp
+pkgver=2.7.2
+pkgrel=1
+pkgdesc="Matsui's CPP implementation precisely conformed to standards"
+arch=(i686 x86_64)
+license=('custom')
+url="http://mcpp.sourceforge.net"
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz )
+depends=(glibc)
+md5sums=('512de48c87ab023a69250edc7a0c7b05')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf ../doc/${pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/not_built/core/mcpp/mcpp-2.6.4-patch b/abs/not_built/core/mcpp/mcpp-2.6.4-patch
new file mode 100644
index 0000000..bbdf09c
--- /dev/null
+++ b/abs/not_built/core/mcpp/mcpp-2.6.4-patch
@@ -0,0 +1,22 @@
+*** src/support.c.orig 2007-05-18 21:31:17.000000000 +0900
+--- src/support.c 2007-09-17 22:11:27.000000000 +0900
+***************
+*** 1678,1686 ****
+ , NULL, (long) c, NULL);
+ case '\t': /* Horizontal space */
+ case ' ':
+! if (mcpp_mode == OLD_PREP) {
+! if ((*(tp - 1) != ' ' && *(tp - 1) != COM_SEP))
+! *(tp - 1) = ' '; /* Squeeze COM_SEP with spaces */
+ } else {
+ if (*(tp - 1) != ' ')
+ *tp++ = ' '; /* Squeeze white spaces */
+--- 1678,1685 ----
+ , NULL, (long) c, NULL);
+ case '\t': /* Horizontal space */
+ case ' ':
+! if (mcpp_mode == OLD_PREP && (*(tp - 1) == COM_SEP)) {
+! *(tp - 1) = ' '; /* Squeeze COM_SEP with spaces */
+ } else {
+ if (*(tp - 1) != ' ')
+ *tp++ = ' '; /* Squeeze white spaces */