summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/procps
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/procps
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/procps')
-rw-r--r--abs/not_built/core/procps/ChangeLog10
-rw-r--r--abs/not_built/core/procps/PKGBUILD27
-rw-r--r--abs/not_built/core/procps/sysctl.conf13
3 files changed, 50 insertions, 0 deletions
diff --git a/abs/not_built/core/procps/ChangeLog b/abs/not_built/core/procps/ChangeLog
new file mode 100644
index 0000000..dddcde3
--- /dev/null
+++ b/abs/not_built/core/procps/ChangeLog
@@ -0,0 +1,10 @@
+2009-05-12 Eric Belanger <eric@archlinux.org>
+
+ * procps 3.2.8-1
+ * Upstream update
+ * Fixed license
+
+2008-10-19 Eric Belanger <eric@archlinux.org>
+
+ * Updated url
+ * Added ChangeLog
diff --git a/abs/not_built/core/procps/PKGBUILD b/abs/not_built/core/procps/PKGBUILD
new file mode 100644
index 0000000..84c3a19
--- /dev/null
+++ b/abs/not_built/core/procps/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 39239 2009-05-14 06:04:46Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=procps
+pkgver=3.2.8
+pkgrel=1
+pkgdesc="Utilities for monitoring your system and processes on your system"
+arch=('i686' 'x86_64')
+url="http://procps.sourceforge.net/"
+license=('GPL' 'LGPL')
+groups=('base')
+depends=('ncurses')
+backup=('etc/sysctl.conf')
+source=(http://procps.sourceforge.net/procps-${pkgver}.tar.gz sysctl.conf)
+md5sums=('9532714b6846013ca9898984ba4cd7e0' '9be3a131a7068aae11418e6dd99e2221')
+sha1sums=('a0c86790569dec26b5d9037e8868ca907acc9829' '9b9a314010d042b5aa487893c06f361531525e6a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i "s:\$(lib64):lib:" Makefile || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" ldconfig=/bin/true install || return 1
+ install -D -m644 "${srcdir}/sysctl.conf" "${pkgdir}/etc/sysctl.conf" || return 1
+ install -d "${pkgdir}/usr/include/proc" || return 1
+ install -m644 proc/*.h "${pkgdir}/usr/include/proc" || return 1
+}
diff --git a/abs/not_built/core/procps/sysctl.conf b/abs/not_built/core/procps/sysctl.conf
new file mode 100644
index 0000000..e3ebc7b
--- /dev/null
+++ b/abs/not_built/core/procps/sysctl.conf
@@ -0,0 +1,13 @@
+#
+# Kernel sysctl configuration
+#
+
+# Disable packet forwarding
+net.ipv4.ip_forward=0
+
+# Disable the magic-sysrq key (console security issues)
+kernel.sysrq = 0
+
+# Enable TCP SYN Cookie Protection
+net.ipv4.tcp_syncookies = 1
+