summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/ttf-bitstream-vera
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/ttf-bitstream-vera
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/ttf-bitstream-vera')
-rw-r--r--abs/not_built/core/ttf-bitstream-vera/PKGBUILD24
-rw-r--r--abs/not_built/core/ttf-bitstream-vera/vera.install20
2 files changed, 44 insertions, 0 deletions
diff --git a/abs/not_built/core/ttf-bitstream-vera/PKGBUILD b/abs/not_built/core/ttf-bitstream-vera/PKGBUILD
new file mode 100644
index 0000000..4fa76b8
--- /dev/null
+++ b/abs/not_built/core/ttf-bitstream-vera/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 77738 2010-04-17 15:45:51Z thayer $
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+pkgname=ttf-bitstream-vera
+pkgver=1.10
+pkgrel=7
+pkgdesc="Bitstream vera fonts"
+arch=('any')
+license=('custom')
+url="http://www.gnome.org/fonts"
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=vera.install
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/1.10/${pkgname}-${pkgver}.tar.bz2)
+md5sums=(bb22bd5b4675f5dbe17c6963d8c00ed6)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir -p ${pkgdir}/usr/share/fonts/TTF
+ install -m644 *.ttf ${pkgdir}/usr/share/fonts/TTF/
+ mkdir -p ${pkgdir}/usr/share/licenses/ttf-bitstream-vera
+ install -m644 COPYRIGHT.TXT ${pkgdir}/usr/share/licenses/ttf-bitstream-vera/LICENSE
+}
+
diff --git a/abs/not_built/core/ttf-bitstream-vera/vera.install b/abs/not_built/core/ttf-bitstream-vera/vera.install
new file mode 100644
index 0000000..4f5212e
--- /dev/null
+++ b/abs/not_built/core/ttf-bitstream-vera/vera.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*