summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/gnome-keyring
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/gnome-keyring
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/gnome-keyring')
-rw-r--r--abs/not_built/extra/gnome-keyring/PKGBUILD28
-rw-r--r--abs/not_built/extra/gnome-keyring/gnome-keyring.install11
-rw-r--r--abs/not_built/extra/gnome-keyring/gnome-keyring.service3
3 files changed, 42 insertions, 0 deletions
diff --git a/abs/not_built/extra/gnome-keyring/PKGBUILD b/abs/not_built/extra/gnome-keyring/PKGBUILD
new file mode 100644
index 0000000..5da3d28
--- /dev/null
+++ b/abs/not_built/extra/gnome-keyring/PKGBUILD
@@ -0,0 +1,28 @@
+#$Id: PKGBUILD 97123 2010-10-26 16:27:27Z ibiru $
+# Maintainer: Jan De Groot <jgc@archlinux.org>
+
+pkgname=gnome-keyring
+pkgver=2.32.1
+pkgrel=1
+pkgdesc="GNOME Password Management daemon"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL')
+depends=('gtk2>=2.22.0' 'dconf')
+makedepends=('intltool' 'pkgconfig' 'python2')
+groups=('gnome')
+options=('!libtool' '!emptydirs')
+url="http://www.gnome.org"
+install=gnome-keyring.install
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.32/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --libexecdir=/usr/lib/gnome-keyring \
+ --with-pam-dir=/lib/security --with-root-certs=/etc/ssl/certs \
+ --disable-schemas-compile
+ make
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/abs/not_built/extra/gnome-keyring/gnome-keyring.install b/abs/not_built/extra/gnome-keyring/gnome-keyring.install
new file mode 100644
index 0000000..e5204bc
--- /dev/null
+++ b/abs/not_built/extra/gnome-keyring/gnome-keyring.install
@@ -0,0 +1,11 @@
+post_install() {
+ usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/abs/not_built/extra/gnome-keyring/gnome-keyring.service b/abs/not_built/extra/gnome-keyring/gnome-keyring.service
new file mode 100644
index 0000000..96ea061
--- /dev/null
+++ b/abs/not_built/extra/gnome-keyring/gnome-keyring.service
@@ -0,0 +1,3 @@
+[D-BUS Service]
+Name=org.gnome.keyring
+Exec=/usr/bin/gnome-keyring-daemon