summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/libgtop
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/libgtop
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/libgtop')
-rw-r--r--abs/not_built/extra/libgtop/PKGBUILD25
-rw-r--r--abs/not_built/extra/libgtop/libgtop.install13
2 files changed, 38 insertions, 0 deletions
diff --git a/abs/not_built/extra/libgtop/PKGBUILD b/abs/not_built/extra/libgtop/PKGBUILD
new file mode 100644
index 0000000..a602fbe
--- /dev/null
+++ b/abs/not_built/extra/libgtop/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 91991 2010-09-28 16:33:41Z ibiru $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libgtop
+pkgver=2.28.2
+pkgrel=1
+pkgdesc="A library that read information about processes and the running system"
+arch=('i686' 'x86_64')
+license=('LGPL')
+depends=('glib2>=2.26' 'libxau' 'texinfo')
+makedepends=('intltool')
+install=libgtop.install
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.28/${pkgname}-${pkgver}.tar.bz2)
+options=('!libtool')
+url="http://www.gnome.org/"
+sha256sums=('49958d7da1f76b257bfd0d557d8ed2b218a5ab0d31b59fed1c32ddf2a1529f5d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --with-libgtop-smp
+ make
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/abs/not_built/extra/libgtop/libgtop.install b/abs/not_built/extra/libgtop/libgtop.install
new file mode 100644
index 0000000..15690f1
--- /dev/null
+++ b/abs/not_built/extra/libgtop/libgtop.install
@@ -0,0 +1,13 @@
+info_dir=/usr/share/info
+
+post_install() {
+ install-info ${info_dir}/libgtop2.info.gz ${info_dir}/dir 2> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ install-info --delete ${info_dir}/libgtop2.info.gz ${info_dir}/dir 2> /dev/null
+}