summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libxcb
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/libxcb')
-rw-r--r--abs/core-testing/libxcb/PKGBUILD32
-rw-r--r--abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch12
-rw-r--r--abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch12
-rw-r--r--abs/core-testing/libxcb/xcb_xlib-no-assert-on-lock.patch30
4 files changed, 0 insertions, 86 deletions
diff --git a/abs/core-testing/libxcb/PKGBUILD b/abs/core-testing/libxcb/PKGBUILD
deleted file mode 100644
index cbe31bd..0000000
--- a/abs/core-testing/libxcb/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# $Id: PKGBUILD 79958 2010-05-09 18:41:21Z jgc $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=libxcb
-pkgver=1.6
-pkgrel=1
-pkgdesc="X11 client-side library"
-arch=(i686 x86_64)
-url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.6' 'libxdmcp' 'libxau')
-makedepends=('pkgconfig' 'libxslt' 'python')
-conflicts=('libx11<1.1.99.2')
-options=('!libtool')
-license=('custom')
-source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
- libxcb-1.1-no-pthread-stubs.patch)
-sha1sums=('b0a6fec4c02ec876f32bbd4b64ffe8a25f0da518'
- '3455e84642283bc91c8313af319002a20bbcbdf4')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/libxcb-1.1-no-pthread-stubs.patch" || return 1
- libtoolize --force --copy || return 1
- aclocal || return 1
- autoconf || return 1
- automake --add-missing || return 1
- ./configure --prefix=/usr --enable-xinput || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
-}
diff --git a/abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch b/abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch
deleted file mode 100644
index f17de1b..0000000
--- a/abs/core-testing/libxcb/libxcb-1.1-no-pthread-stubs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up libxcb-1.1/configure.ac.pthread-stubs libxcb-1.1/configure.ac
---- libxcb-1.1/configure.ac.pthread-stubs 2007-11-04 18:17:11.000000000 -0500
-+++ libxcb-1.1/configure.ac 2007-11-12 10:27:06.000000000 -0500
-@@ -31,7 +31,7 @@ AC_SUBST(HTML_CHECK_RESULT)
-
- # Checks for pkg-config packages
- PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.6)
--NEEDED="pthread-stubs xau >= 0.99.2"
-+NEEDED="xau >= 0.99.2"
- PKG_CHECK_MODULES(NEEDED, $NEEDED)
-
- have_xdmcp="no"
diff --git a/abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch b/abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch
deleted file mode 100644
index 130890e..0000000
--- a/abs/core-testing/libxcb/libxcb-1.1-sloppy-lock.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up libxcb-1.1/src/xcb_conn.c.jx libxcb-1.1/src/xcb_conn.c
---- libxcb-1.1/src/xcb_conn.c.jx 2007-10-28 16:11:18.000000000 -0400
-+++ libxcb-1.1/src/xcb_conn.c 2008-04-22 11:58:05.000000000 -0400
-@@ -63,7 +63,7 @@ static int _xcb_xlib_init(_xcb_xlib *xli
- {
- xlib->lock = 0;
- #ifndef NDEBUG
-- xlib->sloppy_lock = (getenv("LIBXCB_ALLOW_SLOPPY_LOCK") != 0);
-+ xlib->sloppy_lock = 1;
- #endif
- pthread_cond_init(&xlib->cond, 0);
- return 1;
diff --git a/abs/core-testing/libxcb/xcb_xlib-no-assert-on-lock.patch b/abs/core-testing/libxcb/xcb_xlib-no-assert-on-lock.patch
deleted file mode 100644
index a29361b..0000000
--- a/abs/core-testing/libxcb/xcb_xlib-no-assert-on-lock.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/xcb_xlib.c.orig 2006-11-25 22:03:30.000000000 +0000
-+++ src/xcb_xlib.c 2006-11-25 22:19:28.000000000 +0000
-@@ -38,18 +38,20 @@
- void xcb_xlib_lock(xcb_connection_t *c)
- {
- _xcb_lock_io(c);
-- assert(!c->xlib.lock);
-- c->xlib.lock = 1;
-- c->xlib.thread = pthread_self();
-+ if (!c->xlib.lock) {
-+ c->xlib.lock = 1;
-+ c->xlib.thread = pthread_self();
-+ }
- _xcb_unlock_io(c);
- }
-
- void xcb_xlib_unlock(xcb_connection_t *c)
- {
- _xcb_lock_io(c);
-- assert(c->xlib.lock);
-- assert(pthread_equal(c->xlib.thread, pthread_self()));
-- c->xlib.lock = 0;
-- pthread_cond_broadcast(&c->xlib.cond);
-+ if (c->xlib.lock) {
-+ assert(pthread_equal(c->xlib.thread, pthread_self()));
-+ c->xlib.lock = 0;
-+ pthread_cond_broadcast(&c->xlib.cond);
-+ }
- _xcb_unlock_io(c);
- }