summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/alpine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/alpine/PKGBUILD')
-rw-r--r--abs/extra-testing/alpine/PKGBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/abs/extra-testing/alpine/PKGBUILD b/abs/extra-testing/alpine/PKGBUILD
deleted file mode 100644
index 1d75c85..0000000
--- a/abs/extra-testing/alpine/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id: PKGBUILD 64978 2010-01-23 22:24:15Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Fabio Scotoni <fabio@esse.ch>
-
-pkgname=alpine
-pkgver=2.00
-pkgrel=7
-_patchlevel=53
-pkgdesc="The Apache-licensed PINE (a tool for reading, sending, and managing electronic messages)"
-arch=('i686' 'x86_64')
-url="http://www.washington.edu/alpine/"
-license=('APACHE')
-depends=('libldap>=2.4.11' 'heimdal>=1.2.1' 'gettext')
-optdepends=('aspell: for spell-checking support')
-provides=('pine')
-conflicts=('pine')
-replaces=('pine')
-options=('!makeflags')
-source=(ftp://ftp.cac.washington.edu/${pkgname}/${pkgname}.tar.bz2 \
- http://staff.washington.edu/chappa/alpine/patches/alpine-${pkgver}/all_${_patchlevel}.patch.gz \
- 2.00-lpam.patch CVE-2008-5514.patch)
-md5sums=('84e44cbf71ed674800a5d57eed9c1c52' 'c4a85b865f59c095f838617d08b1b123'\
- 'cd3911c16fc6a072e853c0ccfc35857c' '1b52a54a656979116c09fb1d948a4325')
-sha1sums=('dcbd3c5419954f484ccf706feaba31ce48cdebc4' '7396ed92062924c126087dc32b98ccebf98e17cc'\
- '1b39525f91ebd5a9de5a1e04f5554f6fa5f58ae3' 'bc61d76a237ff42b00b3f60f2e6fc5c45e261dbb')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ../all_${_patchlevel}.patch || return 1
- patch -p1 < ../2.00-lpam.patch || return 1
- patch -p1 < ../CVE-2008-5514.patch || return 1
- ./configure --prefix=/usr --without-passfile --without-tcl \
- --disable-shared --with-system-pinerc=/etc/alpine.d/pine.conf \
- --with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
-}