summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/alpine
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/alpine')
-rw-r--r--abs/extra-testing/alpine/2.00-lpam.patch13
-rw-r--r--abs/extra-testing/alpine/CVE-2008-5514.patch20
-rw-r--r--abs/extra-testing/alpine/ChangeLog43
-rw-r--r--abs/extra-testing/alpine/PKGBUILD37
4 files changed, 0 insertions, 113 deletions
diff --git a/abs/extra-testing/alpine/2.00-lpam.patch b/abs/extra-testing/alpine/2.00-lpam.patch
deleted file mode 100644
index 69e66d7..0000000
--- a/abs/extra-testing/alpine/2.00-lpam.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- alpine-2.00.orig/alpine/Makefile.in
-+++ alpine-2.00/alpine/Makefile.in
-@@ -169,7 +169,7 @@
- LIBICONV = @LIBICONV@
- LIBINTL = @LIBINTL@
- LIBOBJS = @LIBOBJS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ -lpam
- LIBTOOL = @LIBTOOL@
- LN = @LN@
- LN_S = @LN_S@
- LTLIBICONV = @LTLIBICONV@
- LTLIBINTL = @LTLIBINTL@
diff --git a/abs/extra-testing/alpine/CVE-2008-5514.patch b/abs/extra-testing/alpine/CVE-2008-5514.patch
deleted file mode 100644
index 594bea0..0000000
--- a/abs/extra-testing/alpine/CVE-2008-5514.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- alpine-2.00/imap/src/c-client/rfc822.c
-+++ alpine-2.00/imap/src/c-client/rfc822.c
-@@ -1351,6 +1351,7 @@
-
- static long rfc822_output_char (RFC822BUFFER *buf,int c)
- {
-+ if ((buf->cur == buf->end) && !rfc822_output_flush (buf)) return NIL;
- *buf->cur++ = c; /* add character, soutr buffer if full */
- return (buf->cur == buf->end) ? rfc822_output_flush (buf) : LONGT;
- }
-@@ -1374,7 +1375,8 @@
- len -= i;
- }
- /* soutr buffer now if full */
-- if (len && !rfc822_output_flush (buf)) return NIL;
-+ if ((len || (buf->cur == buf->end)) && !rfc822_output_flush (buf))
-+ return NIL;
- }
- return LONGT;
- }
diff --git a/abs/extra-testing/alpine/ChangeLog b/abs/extra-testing/alpine/ChangeLog
deleted file mode 100644
index 4c3bf81..0000000
--- a/abs/extra-testing/alpine/ChangeLog
+++ /dev/null
@@ -1,43 +0,0 @@
-2010-01-23 Eric Belanger <eric@archlinux.org>
-
- * alpine 2.00-7
- * Updated patchset to level 53
-
-2009-09-18 Eric Belanger <eric@archlinux.org>
-
- * alpine 2.00-6
- * libldap-2.4 rebuild
-
-2009-09-18 Eric Belanger <eric@archlinux.org>
-
- * alpine 2.00-5
- * Updated patchset to level 52
- * Security fix
-
-2009-09-17 Allan McRae <allan@archlinux.org>
-
- * alpine 2.00-4
- * libldap-2.4 rebuild
-
-2009-02-07 Eric Belanger <eric@archlinux.org>
-
- * alpine 2.00-3
- * Updated patchset to level 20
-
-2008-12-05 Eric Belanger <eric@archlinux.org>
-
- * alpine 2.00-2
- * Rebuilt against heimdal 1.2.1
- * Placed copy of all.patch.gz patch on local ftp (close FS#11964)
-
-2008-09-04 Eric Belanger <eric@archlinux.org>
-
- * alpine 2.00-1
- * Upstream update
- * Replaced install scriptlet with optdepends
-
-2008-03-26 Eric Belanger <eric@archlinux.org>
-
- * alpine 1.10-1
- * Upstream update
- * Added ChangeLog
diff --git a/abs/extra-testing/alpine/PKGBUILD b/abs/extra-testing/alpine/PKGBUILD
deleted file mode 100644
index 1d75c85..0000000
--- a/abs/extra-testing/alpine/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id: PKGBUILD 64978 2010-01-23 22:24:15Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Fabio Scotoni <fabio@esse.ch>
-
-pkgname=alpine
-pkgver=2.00
-pkgrel=7
-_patchlevel=53
-pkgdesc="The Apache-licensed PINE (a tool for reading, sending, and managing electronic messages)"
-arch=('i686' 'x86_64')
-url="http://www.washington.edu/alpine/"
-license=('APACHE')
-depends=('libldap>=2.4.11' 'heimdal>=1.2.1' 'gettext')
-optdepends=('aspell: for spell-checking support')
-provides=('pine')
-conflicts=('pine')
-replaces=('pine')
-options=('!makeflags')
-source=(ftp://ftp.cac.washington.edu/${pkgname}/${pkgname}.tar.bz2 \
- http://staff.washington.edu/chappa/alpine/patches/alpine-${pkgver}/all_${_patchlevel}.patch.gz \
- 2.00-lpam.patch CVE-2008-5514.patch)
-md5sums=('84e44cbf71ed674800a5d57eed9c1c52' 'c4a85b865f59c095f838617d08b1b123'\
- 'cd3911c16fc6a072e853c0ccfc35857c' '1b52a54a656979116c09fb1d948a4325')
-sha1sums=('dcbd3c5419954f484ccf706feaba31ce48cdebc4' '7396ed92062924c126087dc32b98ccebf98e17cc'\
- '1b39525f91ebd5a9de5a1e04f5554f6fa5f58ae3' 'bc61d76a237ff42b00b3f60f2e6fc5c45e261dbb')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ../all_${_patchlevel}.patch || return 1
- patch -p1 < ../2.00-lpam.patch || return 1
- patch -p1 < ../CVE-2008-5514.patch || return 1
- ./configure --prefix=/usr --without-passfile --without-tcl \
- --disable-shared --with-system-pinerc=/etc/alpine.d/pine.conf \
- --with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
-}