summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/motion-svn/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/community/motion-svn/PKGBUILD')
-rw-r--r--abs/extra-testing/community/motion-svn/PKGBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/abs/extra-testing/community/motion-svn/PKGBUILD b/abs/extra-testing/community/motion-svn/PKGBUILD
deleted file mode 100644
index dcbd162..0000000
--- a/abs/extra-testing/community/motion-svn/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Demind <demind@gmail.com>
-pkgname=motion-svn
-pkgver=1
-pkgrel=1
-pkgdesc="Motion is a software motion detector. It grabs images from video4linux devices and/or from webcams."
-arch=('i686' 'x86_64')
-url="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
-license=('GPL2')
-depends=('zlib' 'libjpeg')
-makedepends=('subversion')
-provides=('motion')
-conflicts=('motion')
-install="motion-svn.install"
-source=('rc.motion')
-md5sums=('fc09828564850824f8549d258053e0b6')
-
-_svntrunk=http://www.lavrsen.dk/svn/motion/trunk/
-_svnmod=motion
-
-build() {
- cd $startdir/src
-
- msg "Retrieving sources"
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-
- [ -d ./$_svnmod-build ] && rm -fr ./$_svnmod-build
- cp -r ./$_svnmod ./$_svnmod-build
- cd ./$_svnmod-build
-
- msg "SVN checkout done or server timeout"
- msg "Starting build"
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc
-
- make || return 1
- make DESTDIR=$startdir/pkg/ install || return 1
- install -D -m755 $startdir/src/rc.motion $startdir/pkg/etc/rc.d/motion
- rm -rf $startdir/src/$_svnmod-build
-}
-