summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/motion-svn
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/community/motion-svn')
-rw-r--r--abs/extra-testing/community/motion-svn/PKGBUILD42
-rw-r--r--abs/extra-testing/community/motion-svn/motion-svn.install11
-rw-r--r--abs/extra-testing/community/motion-svn/rc.motion36
3 files changed, 0 insertions, 89 deletions
diff --git a/abs/extra-testing/community/motion-svn/PKGBUILD b/abs/extra-testing/community/motion-svn/PKGBUILD
deleted file mode 100644
index dcbd162..0000000
--- a/abs/extra-testing/community/motion-svn/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Demind <demind@gmail.com>
-pkgname=motion-svn
-pkgver=1
-pkgrel=1
-pkgdesc="Motion is a software motion detector. It grabs images from video4linux devices and/or from webcams."
-arch=('i686' 'x86_64')
-url="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
-license=('GPL2')
-depends=('zlib' 'libjpeg')
-makedepends=('subversion')
-provides=('motion')
-conflicts=('motion')
-install="motion-svn.install"
-source=('rc.motion')
-md5sums=('fc09828564850824f8549d258053e0b6')
-
-_svntrunk=http://www.lavrsen.dk/svn/motion/trunk/
-_svnmod=motion
-
-build() {
- cd $startdir/src
-
- msg "Retrieving sources"
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-
- [ -d ./$_svnmod-build ] && rm -fr ./$_svnmod-build
- cp -r ./$_svnmod ./$_svnmod-build
- cd ./$_svnmod-build
-
- msg "SVN checkout done or server timeout"
- msg "Starting build"
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc
-
- make || return 1
- make DESTDIR=$startdir/pkg/ install || return 1
- install -D -m755 $startdir/src/rc.motion $startdir/pkg/etc/rc.d/motion
- rm -rf $startdir/src/$_svnmod-build
-}
-
diff --git a/abs/extra-testing/community/motion-svn/motion-svn.install b/abs/extra-testing/community/motion-svn/motion-svn.install
deleted file mode 100644
index f88a2fc..0000000
--- a/abs/extra-testing/community/motion-svn/motion-svn.install
+++ /dev/null
@@ -1,11 +0,0 @@
-# arg 1: the new package version
-post_install() {
- echo ""
- echo ">>> An example configuration has been saved to /etc/motion-dispatch.conf"
-}
-
-op=$1
-shift
-[ "$(type -t "$op")" = "function" ] && $op "$@"
-
-# vim:set ts=2 et:
diff --git a/abs/extra-testing/community/motion-svn/rc.motion b/abs/extra-testing/community/motion-svn/rc.motion
deleted file mode 100644
index 7dd027c..0000000
--- a/abs/extra-testing/community/motion-svn/rc.motion
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/bin/motion`
-case "$1" in
- start)
- stat_busy "Starting Motion"
- [ -z "$PID" ] && /usr/bin/motion
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon motion
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping Motion"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon motion
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0